01 Feb 2022

CISA Tells Organizations to Patch CVEs Dating Back to 2014

The US government has added eight more vulnerabilities to a list of CVEs that federal agencies are required to patch, called the Known Exploited Vulnerabilities Catalog. The list was first launched by the Cybersecurity and Infrastructure Security Agency in November 2021, and is an effort to enhance cyber resilience and

Read More